User Tag List

Results 1 to 8 of 8

Thread: Car wont rev, wont idle and is fouling plugs..

  1. #1

    Join Date
    Dec 2015
    Location
    Europe
    Posts
    555
    Thanked
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Car wont rev, wont idle and is fouling plugs..

    Ok so finally got a spare stock motor in while the other one is built, but the pos won't run.

    Can't rev past about 2500-3000, it just stutters and cuts out. Feels like ECU is in safe mode. I got plenty of spares so I've changed the AFM, I've changed ECU, I've changed the TPS, i've looked everywhere for vacuum leaks... I can't think of anything else??? I'm ready to light the car on fire!

    Anyone have any ideas?

    What should the voltage readings be across the AFM wires? I might try add a direct ground to the cable, but can't remember which wire is which.

  2. #2
    Need Input Cozzm0's Avatar
    Join Date
    Jun 2003
    Location
    Sydney Australia
    Posts
    555
    Thanked
    156
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Check the ECU error code to find out WHY its having trouble ?

  3. #3

    Join Date
    Dec 2015
    Location
    Europe
    Posts
    555
    Thanked
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Error code 12 - AFM circuit open or shorted.

    Cozzm0 do you know what the afm wiring should be like so i can check the voltages and the ground?

  4. #4
    Need Input Cozzm0's Avatar
    Join Date
    Jun 2003
    Location
    Sydney Australia
    Posts
    555
    Thanked
    156
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    3 or 4 wire AFM ?

  5. #5
    Need Input Cozzm0's Avatar
    Join Date
    Jun 2003
    Location
    Sydney Australia
    Posts
    555
    Thanked
    156
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    3 wire AFM

    Click image for larger version. 

Name:	3wire.jpg 
Views:	122 
Size:	99.4 KB 
ID:	1286

  6. #6

    Join Date
    Dec 2015
    Location
    Europe
    Posts
    555
    Thanked
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    So much for buying a second hand loom in "good condition". Bloody gumtree... The thing is a mess, absolute dumb ass wiring job! The AFM wire has been cut before or replaced and its not soldered or even crimped. Twisted together and taped over, with exposed wires touching the shielding wire. FML...

    Click image for larger version. 

Name:	20160414_195400.jpg 
Views:	146 
Size:	77.1 KB 
ID:	1285

  7. #7
    Need Input Cozzm0's Avatar
    Join Date
    Jun 2003
    Location
    Sydney Australia
    Posts
    555
    Thanked
    156
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hopefully that hasn't damaged the ECU(s) that you've been trying.

  8. #8

    Join Date
    Dec 2015
    Location
    Europe
    Posts
    555
    Thanked
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Cheers for the diagrams, all good now. Car revs lovely now. Just need to sort out my idle, not working well when cold. But smooth when warm.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •