View Full Version : Issue with checking fault codes

01-11-2018, 09:45 AM
I'm wondering whether someone has experienced the same issue I have and can provide some advice on how to sort it out. I have a series 2 N15 sedan (GA16), and I'm trying to retrieve the fault codes to further diagnose an issue I'm having. As far as I know, I need to bridge the two top right pins on the Consult port and then remove the bridge after a couple of seconds, whilst the key is in in the on position, but not running. I have tried this multiple times with a piece of wire/paperclip etc and no matter what, the check engine light does not flash any codes, not even a code 55. I have also tried a friend's scan tool, which suits multiple cars but does have a Consult adapter, with the key in the on position as well as whilst the car was running, to no avail either. I'm wondering why I'm having this issue? Is there anything else that needs to be done before I can retrieve the fault codes, like put the ECU into diagnostic mode or something like that?

Any help would be greatly appreciated.

Cheers, Jarryd

01-11-2018, 11:08 AM
Does this help?



01-11-2018, 01:00 PM
Hey mate, I watched that video the other day, that's the procedure I have been attempting to do to no avail. I switch the key to the on position, the check engine light comes on and stays on, I bridge the two pins in the top right of the Consult port as shown per the video, remove it after a couple of seconds and the check engine light stays illuminated; there's no change at all. Very odd!

01-11-2018, 04:19 PM
Make sure your plug is orientated correctly according to the video.

what happens when your friends scan tool is connected? it can't connect? maybe there is a wiring issue or the connection inside the plug is so bad the ECU isn't registering the short. what problems are you having ?

01-11-2018, 05:22 PM
It's definitely as per the video, with the 'square edge' of the plug facing to the right.

Yeah that's exactly what was happening. When it was connected it was saying 'could not connect'. I'm not too sure to be honest, I need to have a better look at the plug and see what is going on but it definitely looks fine. The car is all original and hasn't been tampered with. Is there anywhere in particular I should be looking? Or just at the plug and the wires going into it?

The problem is a hesitation on acceleration from around 1250 to 2000rpm where the car completely loses power. It only does this whilst at operating temp. After 2000rpm it runs as per normal, builds power fine all the way to redline. I've been chasing this issue for a while now, and have a thread in the GA section. Since my last post in that I have done the following;

- Swapped leads with a known working set, no change
- Unplugged each lead, the car loses power to each cylinder as you'd expect
- Performed the same test with the injectors
- Tested AFM, by unplugging it as well as a multimeter test. Works fine. Also cleaned it with suitable cleaner.
- Checked spark plugs, they're not very old, they look fine.
- Checked TPS voltage at closed, partially open and wide open per Nissan specs, all good, voltage increases smoothly.
- Cleaned the IACV, and tested resistance per Nissan specs, all good. Tried driving around with it unplugged, no change.
- I've also checked the resistance of the coolant temp sensor which appears fine too. The sensor has a blue plug on it though, which I'm not sure is a genuine sensor. Considering the resistance is all good at different temperatures though I'd assume it's working?
- I replaced the vac lines to the EGR also, and cleaned out the little tube from the EGR valve to the BPT valve. One was completely split but that didn't help either.
- Pulled the vacuum line off of the fuel pressure regulator to see if it let fuel out to see if it had a ruptured diaphragm, that was also fine.

So at the moment I'm at a loss as to what the issue is. I think I've narrowed it down to either the EGR system having issues or alternatively there's an issue with my distributor. It isn't very old however but is aftermarket and it was cheap.

Sorry for the huge post, but hopefully it gives some insight into the issue I've got and where to look next! The next thing I'll do is make some block off plates for the EGR as that's a fairly cheap thing to do and will rule it out as causing the issue. Failing that I'll look at putting a new ignition coil or CAS inside the dizzy, but I'd rather try the cheaper stuff first. Cheers.

02-11-2018, 01:31 PM
This may be a long-shot, but maybe there is crud and sludge in your intake and valves, etc.

How many klicks on the odo?

Try two cans of this stuff.


Cheers . . .

02-11-2018, 04:04 PM
That's something that's definitely on the list to do as well. I have done it before (with the same stuff) but it can't hurt to put another can or two through.

As for the k's, it's just gone over 231,000.

Cheers, Jarryd

02-11-2018, 10:19 PM
One last suggestion.

The FUEL FILTER could be clogged.

How long since last changed.

03-11-2018, 08:48 AM
It's been about 15,000k's max since I replaced the fuel filter. Was either last service or the one before, can't quite remember but it has definitely been done recently

03-11-2018, 01:10 PM
Hmmm . . . I replaced my fuel pump (under back seat) at 100,000 klicks.

The fuel strainer was filthy.

Incidentally, when I had the Red Jett dyno-tuned at ChipTorque, Gold Coast, Lachlan Ridell asked me how the fuel pump was and the strainer's condition. Interesting.


Something like this:

https://www.ebay.com.au/itm/Power-Fuel-Pump-Kit-for-Nissan-Pulsar-N15-Series-1995-2000-I4-2-0L-SR20DE/332723327867?_trkparms=aid%3D555017%26algo%3DPL.CA SSINI%26ao%3D1%26asc%3D20180905084756%26meid%3Dd67 3c14ff65f4f359093ee6d6ed325b0%26pid%3D100506%26rk% 3D1%26rkt%3D1%26%26itm%3D332723327867&_trksid=p2045573.c100506.m3226

ps. If you decided to do this yourself, then there are good posts available. Be very careful with tools around the fuel tank access plate. No sparks!

03-11-2018, 02:42 PM
Thanks for the reminder about the fuel pump mate! It is something I need to put a multimeter on and check. I can guarantee it'd be the original one though, and like you said, the strainer is likely to be filthy. Good advice about the fuel tank too, especially because you need to access it from inside the car!

EDIT: should have asked also mate, did you just put an ebay-spec fuel pump in? Or did you opt for a 'brand name' one?

04-11-2018, 09:52 AM
I purchased the eBay spec unit.


04-11-2018, 10:53 AM
No worries! Good to know that they're a viable option.

04-11-2018, 12:27 PM
No worries! Good to know that they're a viable option.

I was watching 'Wheeler Dealers' recently, and the same symptoms of yours was on their car, Opel GT, I think.

Turned out to be fuel supply problems.

After all the diagnostic checks you've done, it may well be fuel supply.

Over and out.

04-11-2018, 08:34 PM
I'll be sure to check that too. I don't have a fuel pressure gauge but I guess I could always disconnect the fuel feed line at the filter and put it in a jar to see whether there's any issues with pressure when the car is cold, as well as at operating temp.

06-11-2018, 01:09 PM
yeh that's the messy messy messy way to do it.

08-11-2018, 08:21 AM
Speaking from experience, haha? Any idea as to how much fuel would be expected to come out whilst priming the fuel pump, assuming the pump is working as it should?

08-11-2018, 05:27 PM
Fuel pumps need to be tested under pressure. Its pretty pointless pumping into a jar. All that will confirm is if its totally rat **** if it can't pump some fuel with no pressure on it.

09-11-2018, 08:13 AM
Hmm fair enough! I'll see how I go in trying to acquire a fuel pressure test kit then.

23-11-2018, 06:43 AM
Yesterday I blocked off the EGR system, which unfortunately has failed to address the hesitation issue. The BPT valve was blocked up with carbon when I took it off so that would have no doubt been causing some issues when it was all connected. As a result I'd say it is (oddly) running better but it still has the hesitation issue. I'm going to grab a coil today as well as a coolant temp sensor if I can find a decent looking one at the wreckers. I'm also getting my hands on a compression tester on Monday so will check that out, as well as look at the condition of the fuel pump too. The search continues!

10-12-2018, 08:04 AM
Problem solved! So since my last post I did a compression test, which gave results of around 165 psi across all four cylinders. I also tested the fuel pump resistance which was within spec. I noticed when I had the leads and plugs out to do the comp test that one of the spark plug tube seals looked to be sitting a bit strangely around the spark plug tube, and funnily enough the plug I removed from that cylinder had a tiny bit of oil around the bottom of it where it contacts the head once tightened up. I have replaced both the seals and the plugs not that long ago when I changed from an N15 plastic rocker cover to an N14 one to address the same issue but assumed that I'd done something wrong. As it turns out, I had installed the spark plug tube seals the wrong way around; they looked similar to a rear main seal (for example) and I assumed that they were installed with the flat edge-side out. I found out that they are meant to be installed flat-edge side first. So anyways after installing a new set of seals the right way, plus putting a new set of plugs in, she's back to driving as good as gold. The carboned-up EGR system was definitely causing issues too but that has been sorted also per my previous posts. I still can't get any fault codes to show up however!