PDA

View Full Version : Front left hub nut loose n15 sss



Chrisss
09-07-2018, 07:43 PM
Hey guys, I went to go change my front rotors and pads and noticed that the wheel was wobbling quite badly. After further inspection I noticed that the hub nut had come loose and was sitting up against the split pin. Iím wondering if the previous owner of the car forgot to put on a washer or something ?

What is supposed to sit in front of the hub ?


Sent from my iPhone using Tapatalk

Paullus
11-07-2018, 06:09 PM
Are you talking about where the hub connects to the ball joint on the lower control arm, or the nut on the end of the driveshaft? If it's the former then it's just the 22mm nut and the split pin. If it's the latter then there should be a big washer that sits behind the big nut and should be done up fairly tight, although one of mine used to work itself loose.

Having said that a loose driveshaft nut won't cause the wheel to wobble if the wheel nuts are tight. I'd say the bearing needs replacing.

Leroy Peterson
12-07-2018, 09:12 AM
+1 for bearings dying often cause the nut to loose.
I thought it was a 32mm nut for the driveshaft.

Cozzm0
16-07-2018, 06:02 PM
If the CV Shaft nut has come loose for any amount of time it will have eaten the bearing i rekon. Tighten it back up and see how you go but budget for a new bearing at least.

Paullus
17-07-2018, 09:07 PM
+1 for bearings dying often cause the nut to loose.
I thought it was a 32mm nut for the driveshaft.

32mm for the driveshaft, 22mm for the nut that holds the hub into the lower control arm.