User Tag List

Results 1 to 2 of 2

Thread: Odometer Stepper motor

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Join Date
    Jan 2018
    Location
    South Australia
    Posts
    555
    Thanked
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Odometer Stepper motor

    Hey, On my N14 pulsar I recently I pulled apart my gauge cluster to find out why the odometer wasn't working, the cluster has a green circuit with the tacho and black backing, I found that one of the teeth on the gears that drive the odometer were broken so I replaced them and still nothing. I thought to myself that the only other reason it couldn't be working is either because my cluster is stuffed or I need a new stepper motor(the motor that turns the gears). I'm just asking if it's possible if anyone knows the part number or knows where to get a new motor from which would be great. Thanks Corey.

  2. #2
    PhilSSStevenson's Avatar
    Join Date
    Dec 2015
    Location
    Gold Coast Hinterland
    Posts
    555
    Thanked
    43
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The same happened to me with the Red Jett some ten years back.

    I replaced the plastic cog and it made no difference.

    In the end I took the instrument cluster to a shop that fixes that stuff.

    e.g.

    http://www.ottoinstruments.com.au

    Cheers.
    NISSAN Pulsar N14 SSS Oz spec - the SSS cult classic. Owned mine since 1992.

  3. The Following User Says Thank You to PhilSSStevenson For This Useful Post:


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •