User Tag List

Results 1 to 3 of 3

Thread: CV Troubles

  1. #1

    Join Date
    Apr 2016
    Location
    Melbourne
    Posts
    555
    Thanked
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    CV Troubles

    Hi,

    Spent the day doing my CVs and I seemed to have got them in fine however my ABS light was on and my brakes don't quite feel right.

    On closer inspection it seems the ABS ring on the passenger side was slightly hitting the hub knuckle, I noticed as there was some tiny metal shavings on the ABS plug on the hub...

    I shoved the CV about 5mm more in to the hub however the light is still on and I have now cooked my brain trying to figure out what is going on.

    With the passenger side jacked up and the drivers side still on the ground I noticed the passenger wheel spins in neutral when I accelerate however with the hub nut torqued down it doesn't. Is this right?

  2. #2

    Join Date
    Apr 2016
    Location
    Melbourne
    Posts
    555
    Thanked
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    UPDATE: I am losing my mind. The passenger side hub is loose, it has play. Also the ABS ring is grinding against the back of the hub, not good.

    Dad says the CV needs to go in towards the gearbox which I agree with as the ABS ring is too close however if I do this then the split pin hole on the end will no longer be visible as the nut will cover it (it is barely visible now)... Thanks in advance.

  3. #3

    Join Date
    Apr 2016
    Location
    Melbourne
    Posts
    555
    Thanked
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    UPDATE 2: The wheel bearing is ****ed.

  4. The Following User Says Thank You to mezje For This Useful Post:

    Cozzm0 (12-09-2016)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •